import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<path>([a-zA-Z0-9_-]+\\/)+)(?P<dimensions>[0-9]{1,4}x[0-9]{1,4})\\/((?P<mode>[cs])\\/)?((?P<quality>[0-9]{1,3})\\/)?(?P<name>[a-zA-Z_\\.-0-9]+\\.[a-z]{3})";
final String string = "dev/earth/resized/100x100/s/70/earth.jpg\n"
+ "dev/earth/resized/100x100/70/earth.jpg\n"
+ "dev/earth/resized/100x100/s/earth.jpg\n"
+ "dev/earth/resized/100x100/earth.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}