re = /(?P<path>([a-zA-Z0-9_-]+\/)+)(?P<dimensions>[0-9]{1,4}x[0-9]{1,4})\/((?P<mode>[cs])\/)?((?P<quality>[0-9]{1,3})\/)?(?P<name>[a-zA-Z_\.-0-9]+\.[a-z]{3})/m
str = 'dev/earth/resized/100x100/s/70/earth.jpg
dev/earth/resized/100x100/70/earth.jpg
dev/earth/resized/100x100/s/earth.jpg
dev/earth/resized/100x100/earth.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end