using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<path>([a-zA-Z0-9_-]+\/)+)(?P<dimensions>[0-9]{1,4}x[0-9]{1,4})\/((?P<mode>[cs])\/)?((?P<quality>[0-9]{1,3})\/)?(?P<name>[a-zA-Z_\.-0-9]+\.[a-z]{3})";
string input = @"dev/earth/resized/100x100/s/70/earth.jpg
dev/earth/resized/100x100/70/earth.jpg
dev/earth/resized/100x100/s/earth.jpg
dev/earth/resized/100x100/earth.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}