#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\s+(\d+)\s(\d+)\s(.*)$"
Local $sString = "drwxr-xr-x 1 saulo 197609 0 1643302767 img" & @CRLF & _
"-rwxr-xr-x 1 saulo 197609 814 1646247422 folder_files.sh" & @CRLF & _
"-rw-r--r-- 1 saulo 197609 2962 1646247491 README.md" & @CRLF & _
"-rwxr-xr-x 1 saulo 197609 59 1654780176 gitp" & @CRLF & _
"drwxr-xr-x 1 saulo 197609 0 1654780219 pessoal" & @CRLF & _
"-rwxr-xr-x 1 saulo 197609 1022 1654780442 folder_files.py" & @CRLF & _
"-rw-r--r-- 1 saulo 197609 226 1654781546 folder_files.php"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")