package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\s+(\d+)\s(\d+)\s(.*)$`)
var str = `drwxr-xr-x 1 saulo 197609 0 1643302767 img
-rwxr-xr-x 1 saulo 197609 814 1646247422 folder_files.sh
-rw-r--r-- 1 saulo 197609 2962 1646247491 README.md
-rwxr-xr-x 1 saulo 197609 59 1654780176 gitp
drwxr-xr-x 1 saulo 197609 0 1654780219 pessoal
-rwxr-xr-x 1 saulo 197609 1022 1654780442 folder_files.py
-rw-r--r-- 1 saulo 197609 226 1654781546 folder_files.php`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}