# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*\s+(\d+)\s(\d+)\s(.*)$"
test_str = ("drwxr-xr-x 1 saulo 197609 0 1643302767 img\n"
"-rwxr-xr-x 1 saulo 197609 814 1646247422 folder_files.sh\n"
"-rw-r--r-- 1 saulo 197609 2962 1646247491 README.md\n"
"-rwxr-xr-x 1 saulo 197609 59 1654780176 gitp\n"
"drwxr-xr-x 1 saulo 197609 0 1654780219 pessoal\n"
"-rwxr-xr-x 1 saulo 197609 1022 1654780442 folder_files.py\n"
"-rw-r--r-- 1 saulo 197609 226 1654781546 folder_files.php")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.