import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\s+(\\d+)\\s(\\d+)\\s(.*)$";
final String string = "drwxr-xr-x 1 saulo 197609 0 1643302767 img\n"
+ "-rwxr-xr-x 1 saulo 197609 814 1646247422 folder_files.sh\n"
+ "-rw-r--r-- 1 saulo 197609 2962 1646247491 README.md\n"
+ "-rwxr-xr-x 1 saulo 197609 59 1654780176 gitp\n"
+ "drwxr-xr-x 1 saulo 197609 0 1654780219 pessoal\n"
+ "-rwxr-xr-x 1 saulo 197609 1022 1654780442 folder_files.py\n"
+ "-rw-r--r-- 1 saulo 197609 226 1654781546 folder_files.php";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}