const regex = /^.*\s+(\d+)\s(\d+)\s(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\s+(\\d+)\\s(\\d+)\\s(.*)$', 'gm')
const str = `drwxr-xr-x 1 saulo 197609 0 1643302767 img
-rwxr-xr-x 1 saulo 197609 814 1646247422 folder_files.sh
-rw-r--r-- 1 saulo 197609 2962 1646247491 README.md
-rwxr-xr-x 1 saulo 197609 59 1654780176 gitp
drwxr-xr-x 1 saulo 197609 0 1654780219 pessoal
-rwxr-xr-x 1 saulo 197609 1022 1654780442 folder_files.py
-rw-r--r-- 1 saulo 197609 226 1654781546 folder_files.php`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}