$re = '/^.*\s+(\d+)\s(\d+)\s(.*)$/m';
$str = 'drwxr-xr-x 1 saulo 197609 0 1643302767 img
-rwxr-xr-x 1 saulo 197609 814 1646247422 folder_files.sh
-rw-r--r-- 1 saulo 197609 2962 1646247491 README.md
-rwxr-xr-x 1 saulo 197609 59 1654780176 gitp
drwxr-xr-x 1 saulo 197609 0 1654780219 pessoal
-rwxr-xr-x 1 saulo 197609 1022 1654780442 folder_files.py
-rw-r--r-- 1 saulo 197609 226 1654781546 folder_files.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);