#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-(?:[A-Za-z0-9]{4}){2,8}$"
Local $sString = "name-ASDk" & @CRLF & _
"name-ASDk12" & @CRLF & _
"name-ASDk1234" & @CRLF & _
"name-ASDFghjk1234" & @CRLF & _
"name_name-ASDFghjk1234" & @CRLF & _
"name-ASDg1234" & @CRLF & _
"name-ASDg1234ASDg1234" & @CRLF & _
"name-ASDg1234ASDg1234" & @CRLF & _
"name-ASDg1234ASDg1234" & @CRLF & _
"name-ASDg1234ASDg1234ASDg1234ASDg1234" & @CRLF & _
"name-ASDg1234ASDg1234ASDg1234ASDg12341234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")