use strict;
my $str = 'name-ASDk
name-ASDk12
name-ASDk1234
name-ASDFghjk1234
name_name-ASDFghjk1234
name-ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234ASDg1234ASDg1234
name-ASDg1234ASDg1234ASDg1234ASDg12341234';
my $regex = qr/-(?:[A-Za-z0-9]{4}){2,8}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}