import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-(?:[A-Za-z0-9]{4}){2,8}$";
final String string = "name-ASDk\n"
+ "name-ASDk12\n"
+ "name-ASDk1234\n"
+ "name-ASDFghjk1234\n"
+ "name_name-ASDFghjk1234\n"
+ "name-ASDg1234\n"
+ "name-ASDg1234ASDg1234\n"
+ "name-ASDg1234ASDg1234\n"
+ "name-ASDg1234ASDg1234\n"
+ "name-ASDg1234ASDg1234ASDg1234ASDg1234\n"
+ "name-ASDg1234ASDg1234ASDg1234ASDg12341234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}