const regex = /-(?:[A-Za-z0-9]{4}){2,8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-(?:[A-Za-z0-9]{4}){2,8}$', 'gm')
const str = `name-ASDk
name-ASDk12
name-ASDk1234
name-ASDFghjk1234
name_name-ASDFghjk1234
name-ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234ASDg1234ASDg1234
name-ASDg1234ASDg1234ASDg1234ASDg12341234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}