$re = '/-(?:[A-Za-z0-9]{4}){2,8}$/m';
$str = 'name-ASDk
name-ASDk12
name-ASDk1234
name-ASDFghjk1234
name_name-ASDFghjk1234
name-ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234ASDg1234ASDg1234
name-ASDg1234ASDg1234ASDg1234ASDg12341234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);