re = /-(?:[A-Za-z0-9]{4}){2,8}$/m
str = 'name-ASDk
name-ASDk12
name-ASDk1234
name-ASDFghjk1234
name_name-ASDFghjk1234
name-ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234
name-ASDg1234ASDg1234ASDg1234ASDg1234
name-ASDg1234ASDg1234ASDg1234ASDg12341234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end