import re
regex = re.compile(r"-(?:[A-Za-z0-9]{4}){2,8}$", flags=re.MULTILINE)
test_str = ("name-ASDk\n"
"name-ASDk12\n"
"name-ASDk1234\n"
"name-ASDFghjk1234\n"
"name_name-ASDFghjk1234\n"
"name-ASDg1234\n"
"name-ASDg1234ASDg1234\n"
"name-ASDg1234ASDg1234\n"
"name-ASDg1234ASDg1234\n"
"name-ASDg1234ASDg1234ASDg1234ASDg1234\n"
"name-ASDg1234ASDg1234ASDg1234ASDg12341234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")