using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Diagnostic-Code[\s\S]*?[\r\n]{2}";
string input = @"...
Status: 5.0.0
Diagnostic-Code: X-Postfix; skalio.com
*this*
*should*
*be included too*
--EA7634814EFB9.1516804532/mail.example.com
Content-Description: Undelivered Message
...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}