import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Diagnostic-Code[\\s\\S]*?[\\r\\n]{2}";
final String string = "...\n"
+ "Status: 5.0.0\n"
+ "Diagnostic-Code: X-Postfix; skalio.com\n"
+ "*this*\n"
+ "*should*\n"
+ "*be included too*\n\n"
+ "--EA7634814EFB9.1516804532/mail.example.com\n"
+ "Content-Description: Undelivered Message\n"
+ "...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}