const regex = /Diagnostic-Code[\s\S]*?[\r\n]{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Diagnostic-Code[\\s\\S]*?[\\r\\n]{2}', 'g')
const str = `...
Status: 5.0.0
Diagnostic-Code: X-Postfix; skalio.com
*this*
*should*
*be included too*
--EA7634814EFB9.1516804532/mail.example.com
Content-Description: Undelivered Message
...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}