import re
regex = re.compile(r"Diagnostic-Code[\s\S]*?[\r\n]{2}")
test_str = ("...\n"
"Status: 5.0.0\n"
"Diagnostic-Code: X-Postfix; skalio.com\n"
"*this*\n"
"*should*\n"
"*be included too*\n\n"
"--EA7634814EFB9.1516804532/mail.example.com\n"
"Content-Description: Undelivered Message\n"
"...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")