re = /Diagnostic-Code[\s\S]*?[\r\n]{2}/
str = '...
Status: 5.0.0
Diagnostic-Code: X-Postfix; skalio.com
*this*
*should*
*be included too*
--EA7634814EFB9.1516804532/mail.example.com
Content-Description: Undelivered Message
...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end