package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Diagnostic-Code[\s\S]*?[\r\n]{2}`)
var str = `...
Status: 5.0.0
Diagnostic-Code: X-Postfix; skalio.com
*this*
*should*
*be included too*
--EA7634814EFB9.1516804532/mail.example.com
Content-Description: Undelivered Message
...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}