#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(TTN-.*$)"
Local $sString = "Oct 20 16:34:59 artguard TTN-fasdkjgqoibvdfhivqeib" & @CRLF & _
"Oct 20 16:34:59 artguard TTN-2f6+a15dfas6d1fa5sdf16asd1" & @CRLF & _
"Oct 20 16:34:59 artguard TTN-21938hfe9un923nru913n wed2uc" & @CRLF & _
"Oct 20 16:34:59 artguard TTN-xxxxxxxxxxxxxxxxxxxxxxxfdskjhfsd" & @CRLF & _
"Oct 20 16:34:59 artguard TTN-sdhfiabaofsdj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")