using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(TTN-.*$)";
string input = @"Oct 20 16:34:59 artguard TTN-fasdkjgqoibvdfhivqeib
Oct 20 16:34:59 artguard TTN-2f6+a15dfas6d1fa5sdf16asd1
Oct 20 16:34:59 artguard TTN-21938hfe9un923nru913n wed2uc
Oct 20 16:34:59 artguard TTN-xxxxxxxxxxxxxxxxxxxxxxxfdskjhfsd
Oct 20 16:34:59 artguard TTN-sdhfiabaofsdj";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}