package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(TTN-.*$)`)
var str = `Oct 20 16:34:59 artguard TTN-fasdkjgqoibvdfhivqeib
Oct 20 16:34:59 artguard TTN-2f6+a15dfas6d1fa5sdf16asd1
Oct 20 16:34:59 artguard TTN-21938hfe9un923nru913n wed2uc
Oct 20 16:34:59 artguard TTN-xxxxxxxxxxxxxxxxxxxxxxxfdskjhfsd
Oct 20 16:34:59 artguard TTN-sdhfiabaofsdj`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}