import Foundation
let pattern = #"(TTN-.*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Oct 20 16:34:59 artguard TTN-fasdkjgqoibvdfhivqeib
Oct 20 16:34:59 artguard TTN-2f6+a15dfas6d1fa5sdf16asd1
Oct 20 16:34:59 artguard TTN-21938hfe9un923nru913n wed2uc
Oct 20 16:34:59 artguard TTN-xxxxxxxxxxxxxxxxxxxxxxxfdskjhfsd
Oct 20 16:34:59 artguard TTN-sdhfiabaofsdj
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)