re = /(TTN-.*$)/m
str = 'Oct 20 16:34:59 artguard TTN-fasdkjgqoibvdfhivqeib
Oct 20 16:34:59 artguard TTN-2f6+a15dfas6d1fa5sdf16asd1
Oct 20 16:34:59 artguard TTN-21938hfe9un923nru913n wed2uc
Oct 20 16:34:59 artguard TTN-xxxxxxxxxxxxxxxxxxxxxxxfdskjhfsd
Oct 20 16:34:59 artguard TTN-sdhfiabaofsdj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end