import re
regex = re.compile(r"(TTN-.*$)", flags=re.MULTILINE)
test_str = ("Oct 20 16:34:59 artguard TTN-fasdkjgqoibvdfhivqeib\n"
"Oct 20 16:34:59 artguard TTN-2f6+a15dfas6d1fa5sdf16asd1\n"
"Oct 20 16:34:59 artguard TTN-21938hfe9un923nru913n wed2uc\n"
"Oct 20 16:34:59 artguard TTN-xxxxxxxxxxxxxxxxxxxxxxxfdskjhfsd\n"
"Oct 20 16:34:59 artguard TTN-sdhfiabaofsdj")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")