import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(TTN-.*$)";
final String string = "Oct 20 16:34:59 artguard TTN-fasdkjgqoibvdfhivqeib\n"
+ "Oct 20 16:34:59 artguard TTN-2f6+a15dfas6d1fa5sdf16asd1\n"
+ "Oct 20 16:34:59 artguard TTN-21938hfe9un923nru913n wed2uc\n"
+ "Oct 20 16:34:59 artguard TTN-xxxxxxxxxxxxxxxxxxxxxxxfdskjhfsd\n"
+ "Oct 20 16:34:59 artguard TTN-sdhfiabaofsdj";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}