#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)^([^?#]*?sheet/)pub(.*)(&[a-z=]*)$"
Local $sString = "aaa/bbbbb/ccc.d:abcsheet/pub/more/here?aa=0&output=html"
Local $sSubst = "$1ccc$2#gid=0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)