$re = '~^([^?#]*?sheet/)pub(.*)(&[a-z=]*)$~i';
$str = 'aaa/bbbbb/ccc.d:abcsheet/pub/more/here?aa=0&output=html';
$subst = "$1ccc$2#gid=0";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;