package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^([^?#]*?sheet/)pub(.*)(&[a-z=]*)$`)
var str = []byte(`aaa/bbbbb/ccc.d:abcsheet/pub/more/here?aa=0&output=html`)
var substitution = []byte("$1ccc$2#gid=0")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}