// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^([^?#]*?sheet/)pub(.*)(&[a-z=]*)$").unwrap();
let string = "aaa/bbbbb/ccc.d:abcsheet/pub/more/here?aa=0&output=html";
let substitution = "$1ccc$2#gid=0";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}