using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^?#]*?sheet/)pub(.*)(&[a-z=]*)$";
string substitution = @"$1ccc$2#gid=0";
string input = @"aaa/bbbbb/ccc.d:abcsheet/pub/more/here?aa=0&output=html";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}