re = /^([^?#]*?sheet\/)pub(.*)(&[a-z=]*)$/i
str = 'aaa/bbbbb/ccc.d:abcsheet/pub/more/here?aa=0&output=html'
subst = '$1ccc$2#gid=0'
result = str.sub(re, subst)
# Print the result of the substitution
puts result