import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^?#]*?sheet/)pub(.*)(&[a-z=]*)$";
final String string = "aaa/bbbbb/ccc.d:abcsheet/pub/more/here?aa=0&output=html";
final String subst = "$1ccc$2#gid=0";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}