const regex = new RegExp('(Avenue|Lane|Road|Boulevard|Drive|Street|Ave|Dr|Rd|Blvd|Ln|St)\\s+(\\S+)\\s*(.*)', 'gi')
const str = `N MONON AVE FRANCESVILLE W YELLOW ST`;
const subst = `\1 & \3 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);