import re
regex = re.compile(r"(Avenue|Lane|Road|Boulevard|Drive|Street|Ave|Dr|Rd|Blvd|Ln|St)\s+(\S+)\s*(.*)", flags=re.IGNORECASE)
test_str = "N MONON AVE FRANCESVILLE W YELLOW ST"
subst = "\\1 & \\3 \\2"
result = regex.sub(subst, test_str)
if result:
print(result)