import Foundation
let pattern = #"(Avenue|Lane|Road|Boulevard|Drive|Street|Ave|Dr|Rd|Blvd|Ln|St)\s+(\S+)\s*(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"N MONON AVE FRANCESVILLE W YELLOW ST"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 & \3 \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)