#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+ ([\w-]+(?: [\w-]+)*) \b(?:small|medium|large)\b"
Local $sString = "Lyreco A-Type small 2i" & @CRLF & _
"Lyreco C-Type small 4i" & @CRLF & _
"Lyreco N-Part medium" & @CRLF & _
"Lyreco STU MT small 4i" & @CRLF & _
"Lyreco N-Type medium 4i" & @CRLF & _
"Lyreco C-Type medium 2i" & @CRLF & _
"Lyreco SNU medium 2i" & @CRLF & _
"Lyreco K-part small 4i" & @CRLF & _
"Lyreco K-Part medium" & @CRLF & _
"Lyreco SNU small 2i" & @CRLF & _
"Lyreco C-Part large 2i" & @CRLF & _
"Lyreco N-Type large 4i"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")