using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+ ([\w-]+(?: [\w-]+)*) \b(?:small|medium|large)\b";
string input = @"Lyreco A-Type small 2i
Lyreco C-Type small 4i
Lyreco N-Part medium
Lyreco STU MT small 4i
Lyreco N-Type medium 4i
Lyreco C-Type medium 2i
Lyreco SNU medium 2i
Lyreco K-part small 4i
Lyreco K-Part medium
Lyreco SNU small 2i
Lyreco C-Part large 2i
Lyreco N-Type large 4i";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}