// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w+ ([\w-]+(?: [\w-]+)*) \b(?:small|medium|large)\b").unwrap();
let string = "Lyreco A-Type small 2i
Lyreco C-Type small 4i
Lyreco N-Part medium
Lyreco STU MT small 4i
Lyreco N-Type medium 4i
Lyreco C-Type medium 2i
Lyreco SNU medium 2i
Lyreco K-part small 4i
Lyreco K-Part medium
Lyreco SNU small 2i
Lyreco C-Part large 2i
Lyreco N-Type large 4i";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}