re = /\w+ ([\w-]+(?: [\w-]+)*) \b(?:small|medium|large)\b/m
str = 'Lyreco A-Type small 2i
Lyreco C-Type small 4i
Lyreco N-Part medium
Lyreco STU MT small 4i
Lyreco N-Type medium 4i
Lyreco C-Type medium 2i
Lyreco SNU medium 2i
Lyreco K-part small 4i
Lyreco K-Part medium
Lyreco SNU small 2i
Lyreco C-Part large 2i
Lyreco N-Type large 4i'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end