# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+ ([\w-]+(?: [\w-]+)*) \b(?:small|medium|large)\b"
test_str = ("Lyreco A-Type small 2i\n"
"Lyreco C-Type small 4i\n"
"Lyreco N-Part medium\n"
"Lyreco STU MT small 4i\n"
"Lyreco N-Type medium 4i\n"
"Lyreco C-Type medium 2i\n"
"Lyreco SNU medium 2i\n"
"Lyreco K-part small 4i\n"
"Lyreco K-Part medium\n"
"Lyreco SNU small 2i\n"
"Lyreco C-Part large 2i\n"
"Lyreco N-Type large 4i")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.