const regex = /\w+ ([\w-]+(?: [\w-]+)*) \b(?:small|medium|large)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+ ([\\w-]+(?: [\\w-]+)*) \\b(?:small|medium|large)\\b', 'gm')
const str = `Lyreco A-Type small 2i
Lyreco C-Type small 4i
Lyreco N-Part medium
Lyreco STU MT small 4i
Lyreco N-Type medium 4i
Lyreco C-Type medium 2i
Lyreco SNU medium 2i
Lyreco K-part small 4i
Lyreco K-Part medium
Lyreco SNU small 2i
Lyreco C-Part large 2i
Lyreco N-Type large 4i`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}