import Foundation
let pattern = #"\w+ ([\w-]+(?: [\w-]+)*) \b(?:small|medium|large)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Lyreco A-Type small 2i
Lyreco C-Type small 4i
Lyreco N-Part medium
Lyreco STU MT small 4i
Lyreco N-Type medium 4i
Lyreco C-Type medium 2i
Lyreco SNU medium 2i
Lyreco K-part small 4i
Lyreco K-Part medium
Lyreco SNU small 2i
Lyreco C-Part large 2i
Lyreco N-Type large 4i
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)