# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b'\b/\\'/g;t' <<< "$sql = INSERT INTO my_table VALUES ( 123, '456', 'Don't fail', 'hellow world' )"