using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b'\b";
string substitution = @"\\'";
string input = @"$sql = INSERT INTO my_table VALUES ( 123, '456', 'Don't fail', 'hellow world' )";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}