$re = '/\b\'\b/';
$str = '$sql = INSERT INTO my_table VALUES ( 123, \'456\', \'Don\'t fail\', \'hellow world\' )';
$subst = "\\'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;