use strict;
my $str = '$sql = INSERT INTO my_table VALUES ( 123, \'456\', \'Don\'t fail\', \'hellow world\' )';
my $regex = qr/\b'\b/p;
my $subst = '\\\\\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";